Tag Archives: Programming Opinion

Programming Style–Kendo & jQuery

Which of the following do you prefer? Which is easier to read? Which is easier to write? Which is easier to maintain?   var dataItem = this.target().closest(“.k-grid”).data(“kendoGrid”).dataSource.getByUid(this.target().closest(“tr”).data(“uid”)); Or… var dataItem = this.target() .closest(“.k-grid”) .data(“kendoGrid”) .dataSource .getByUid(this.target().closest(“tr”).data(“uid”)); Or… var grid = … Continue reading

Posted in JavaScript, Kendo, Languages, Opinion, Programming | Tagged | 4 Comments